Start a new thread

My Camellia, grown in a pot, has suffered from its buds failing to open for the last 3 years. I repotted it last year,in the hope it would flower properly this year but the same thing has happened. It is smothered in buds but none of them open. I have another Camellia in a pot which has been beautiful. Any thoughts?

torsi

I know that the buds start to form from August onward for the flowering in spring. From Aug on you must water for good bud development 

Gold1locks

A method of improving water retention is to remove it from its pot and trim an inch or so from all round the rootball using a serrated knife (I use a knife used to cut plasterboard - costs less than £2 and has a stout handle and deeply serrated teeth). Then mix water retaining granules with fresh compost and pack this around the gap between the rootball and pot. Make sure it is regularly watered from summer until autumn. 

I agree about the watering.  If you don't water enough the year before a camellia won't flower the next.  I water mine (also in a pot), very well, twice a week during the previous summer, maybe even more if it is very hot and mine has flowered wonderfully every year for 4 years.

(One problem I did have this year was due to the mad weather - the buds were all coming out nicely then we had that ridiculously hot couple of weeks in March and a lot of them dropped off or didn't come out.  Now the weather is back to normal the buds are opening up again they way they should.  I know that won't explain your problem for the past three years but if yours is in direct sun maybe it doesn't like that?)

Thank you. The camellia is always on our watering system but maybe that isnt enough so will try extra watering during the summer.

Sign up or log in to post a reply