London (change)
Today 20°C / 11°C
Tomorrow 18°C / 10°C
7 messages
26/07/2013 at 22:56

Last year my hibiscus (about 1m tall) produced 1 flower bud and therefore one flower. I put it down to the weather we had last year. And would you believe it...one bud again this year!! It has put on growth, been feed in spring, kept well waterd in this dry spell...what is going on? Any ideas?  Flummoxed in Essex!

26/07/2013 at 23:39

Did you prune? 

27/07/2013 at 10:25

Never been pruned. Bought it in flower about 3 years ago and only ever had 1 flower each year....its put on growth, is disease free, resides in a sheltered part of the garden, gets good sun... I just don't understand it

02/08/2013 at 22:45

Ages to respond, Daintiness, cos of no email reminders.  I recently bought a hibiscus (in bud) and the nursery told me that it must be pruned, and the harder the better as it flowers only on new growth.  I have only had it ten minutes and therefore have not had to put this in to practice, but that is what I was told ...

04/08/2013 at 19:37

Mine's never been pruned so has new growth every year. I don't think that is it but then...I've got no flowers! Maybe I shall prune part of the bush and see what happens next year - seems a shame as it is a lovely shape and size and I can't justify it  

04/08/2013 at 23:07

I thought I'd have a look around before I go chopping bits off mine (next Spring) and found this ... http://www.garden-grower.com/shrubs/hibiscus.shtml

04/08/2013 at 23:23

I planted 4 three seasons ago, and have yet to see a flower on any of them.  Patience is a virtue - and seeing as I don't have many of them (virtues) I am putting all my efforts into perfecting that one.

If I ever do get a flower, pictures will be proudly posted on here!!

email image
7 messages